Data table load cannot read DateType?

I cannot read a data table i wrote in another WF, because apparently DateType
can only be written but not loaded?

Did you write it to the PostgreSQL DB or is it a Parquet file?

I tried to load a PostgreSQL DB.

OK, I think I faced similar issues in the past:

Data types across data bases (DBs) are somewhat heterogenous. ONE DATA cannot adopt all data types out there inherently. I think you produced a translation conflict between ONE DATA and PostgreSQL DB.

Solution: In my case, I created a ONE DATA Connection to the PostgreSQL DB and used the Database Connection Load Processor to read tables from the PostgreSQL DB. The processor itself has the power to do some ‘translation’ work on its own. Should the issue still not be resolved, you can specifically determine the target data types for each column via SQL statement in the processor configuration. For hardship cases there is also an option to automatically cast everything to STRING.

However, you could also make sure to choose a compatible data type already when writing data to the PostgreSQL DB.

1 Like