Access to schedules without a project

I recently observed the following: I wanted to delete an old (deprecated) workflow. However, when I try to delete it, I get the following error message:

Scheduled workflows cannot be deleted. Please delete the corresponding schedules first.

However, there are no schedules in this project (and this WF is not shared to any other projects). I then tried to access the schedule listed in the API response. However, I get a 403 error when trying to access the schedule:

User with id xxx is not allowed to read schedule with id xxx.

As I am Domain Admin, I did not expect that I would not have access to a schedule.

I then tried the same thing (API request for the schedule ID) with the superadmin, and this works. I can see that the schedule is not assigned to any projects, and the owner is a Domain Admin as well.

Is it true that a Domain Admins does not have access to resources that are not part of any project?


for (very) old resources it is possible that they have no project assigned. As resources are assigned to a domain by the projects they belong to, the resource thus is also in no domain. Thus you can’t access it as domain administrator, because it does not belong to your administrated domain. Only the superadmin and the resource owner can access the resource in this case.
As far as I know resources need to have a project assignment for some time now, so this case should only appear for very old resources.